Scheduled Maintenance Started
Incident Report for Splashtop
Resolved
maintenance completed at 1 am PTD time, UTC 08:00.
Posted 4 months ago. Jul 01, 2017 - 03:25 PDT
Monitoring
Our servers are undergoing scheduled maintenance at this time for about 1 hour. We apologize for any inconvenience this may cause.
Posted 4 months ago. Jun 30, 2017 - 23:59 PDT