Scheduled Maintenance Completed
Incident Report for Splashtop
Resolved
This incident has been resolved.
Posted 3 months ago. Aug 19, 2017 - 09:26 PDT
Investigating
Our scheduled maintenance has completed. All services are back to normal. We apologize for any inconvenience this may have caused.
Posted 3 months ago. Aug 19, 2017 - 00:47 PDT