Scheduled Maintenance Started
Incident Report for Splashtop
Resolved
Our scheduled maintenance has completed. All services are back to normal. We apologize for any inconvenience this may have caused.
Posted about 1 month ago. Aug 19, 2017 - 00:46 PDT
Monitoring
Our servers are undergoing scheduled maintenance at this time for about 1 hour. We apologize for any inconvenience this may cause.
Posted about 1 month ago. Aug 19, 2017 - 00:00 PDT