Service interruption
Incident Report for Splashtop
Resolved
Due to the fixes from earlier today, some overloading of the servers occurred. We upscaled the servers to remediate the issue. Sorry for the inconvenience.
Posted Oct 30, 2023 - 13:16 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 30, 2023 - 12:09 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 30, 2023 - 11:49 PDT
Investigating
Our servers are currently experiencing an issue. You might not be able to access your remote computers at this time. Our engineers are working to resolve it as soon as possible. We apologize for the inconvenience.
Posted Oct 30, 2023 - 11:32 PDT
This incident affected: Splashtop remote desktop service (Global).