Intermittently unable to reach Splashtop Servers
Incident Report for Splashtop
Resolved
This incident has been resolved.
Posted Dec 04, 2023 - 06:50 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 04, 2023 - 05:51 PST
Investigating
Our servers are currently experiencing an issue. You might not be able to log in Splashtop apps. Our engineers are working to resolve it as soon as possible. We apologize for the inconvenience.
Posted Dec 04, 2023 - 05:24 PST
This incident affected: Splashtop remote desktop service (Global).