Our AWS California servers are experiencing degraded performance
Incident Report for Splashtop
Resolved
situation resolved. service back to normal.
Posted 10 months ago. Feb 09, 2017 - 18:53 PST
Investigating
we are investigating.
Posted 10 months ago. Feb 09, 2017 - 18:35 PST