Invalid SSL certificate
Incident Report for Splashtop
Resolved
This issue has been identified and resolved. Sorry for the inconvenience.
Posted 11 months ago. Dec 06, 2016 - 09:28 PST
Investigating
When accessing the Splashtop web console at my.splashtop.com, you may see an error message stating invalid SSL certificate. We're investigating to see which of the web server instances has this issue.
Posted 11 months ago. Dec 06, 2016 - 08:57 PST