Service interruption
Incident Report for Splashtop
Resolved
we have resolved the issue.
Posted about 1 year ago. Nov 10, 2016 - 15:55 PST
Investigating
Our servers are currently experiencing an issue. You might not be able to access your remote computers at this time. Our engineers are working to resolve it as soon as possible. We apologize for the inconvenience.
Posted about 1 year ago. Nov 10, 2016 - 15:01 PST