Service degradation
Incident Report for Splashtop
Resolved
This incident has been resolved.
Posted almost 2 years ago. Mar 29, 2017 - 12:49 PDT
Monitoring
Splashtop service is back to normal for the affected users.
Posted almost 2 years ago. Mar 29, 2017 - 12:47 PDT
Update
Update that website, my.splashtop.com is also affected.
Posted almost 2 years ago. Mar 29, 2017 - 12:30 PDT
Investigating
Some customers are reporting inability to log in or connect to certain computers. We are investigating and working to resolve as soon as possible. Our apologies for the issues.
Posted almost 2 years ago. Mar 29, 2017 - 10:36 PDT