A fix has been implemented and we are monitoring the results.
Posted Jun 13, 2023 - 22:40 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 13, 2023 - 20:26 PDT
Investigating
We regret to inform you that we are currently experiencing a service issue that is affecting our normal operations. We understand the inconvenience this may cause, and we apologize for any disruptions to your service experience.
The issue is affecting the following services for some of our users: Intermittently unable to reach Splashtop Servers
Our technical team is actively working to resolve the issue and restore the affected services as quickly as possible. We have already initiated an investigation into the root cause of the outage and are implementing appropriate measures to prevent similar incidents in the future.
We understand that this situation may be frustrating for you, especially if you rely on our services for critical operations. Our team is committed to resolving the issue promptly and minimizing any inconvenience caused.
If you have any urgent concerns or require additional assistance, please don't hesitate to reach out to our customer support team.
We sincerely apologize for the inconvenience caused by this service issue. We greatly appreciate your patience and understanding as we work diligently to restore normal operations.
Thank you for your continued support.
Posted Jun 13, 2023 - 14:02 PDT
This incident affected: Splashtop remote desktop service (Global).