regional service degradation
Incident Report for Splashtop
Postmortem

Between 10:20AM-10:40AM PDT, some of our servers in the US West Coast region experienced intermittent network issues. We promptly scaled up and failed over to other servers in the West Coast region. During this time, user sessions handled by the affected servers were dropped. All connectivity should have returned to normal after user endpoints automatically re-attached to new servers. Duration of connectivity issues for the affected users should be in the range of 15-30 minutes.
We apologize for the delayed posting of information for this incident.

Posted Mar 24, 2020 - 16:12 PDT

Resolved
This incident has been resolved.
Posted Mar 24, 2020 - 14:11 PDT
Update
we have identified the affected datacenter in US west region.
Posted Mar 24, 2020 - 14:07 PDT
Investigating
We've just confirmed that one of the datacenters had degraded network performance this morning between 10:20am to 10:40am PDT resulting in slower-than-normal connections and some disconnections.  Connections were automatically rerouted to redundant servers, and all services are recovered and performing normally.
Posted Mar 24, 2020 - 14:02 PDT
This incident affected: Splashtop remote desktop service.