High Splashtop Server Loading
Incident Report for Splashtop
Resolved
Problem identified and resolved. We are investigating to make improvements and prevent future occurrences.
Posted 5 months ago. Jul 24, 2018 - 14:08 PDT
Update
We've brought server loading back to normal. Please try again. We are continuing to investigate and monitor and will update further.
Posted 5 months ago. Jul 24, 2018 - 13:03 PDT
Investigating
Splashtop servers are seeing higher than expected loading at the moment. We are investigating. Some customer may have intermittent availability.
Posted 5 months ago. Jul 24, 2018 - 11:33 PDT
This incident affected: Splashtop remote desktop service.