sos.splashtop.com is not accessible
Incident Report for Splashtop
Resolved
removed the bad instance and restored the service.
Posted 7 months ago. Apr 30, 2018 - 12:00 PDT
Investigating
we are investigating.
Posted 7 months ago. Apr 30, 2018 - 11:43 PDT