In certain regions, customers are experiencing issues related to disconnects/reconnects or poor performance
Incident Report for Splashtop
Resolved
This incident has been resolved.
Posted Sep 04, 2023 - 00:20 PDT
Monitoring
All operations are returning to normal, we will continue to monitor. If you are experiencing any issue, we appreciate you reaching out to us.
Posted Sep 04, 2023 - 00:04 PDT
Update
System maintenance have been completed for most regions and operations is returning to normal.
Posted Sep 03, 2023 - 11:18 PDT
Update
We are continuing to work on the fix and mitigate the impact. We want to emphasize how much we value and appreciate your patience throughout this process.
Posted Sep 01, 2023 - 12:18 PDT
Identified
Issue identified and network recovery is under way.
Posted Aug 31, 2023 - 09:58 PDT
Update
We are continuing to investigate this issue. We appreciate your patience!
Posted Aug 30, 2023 - 14:42 PDT
Update
We are continuing to investigate this issue.
Posted Aug 29, 2023 - 10:00 PDT
Investigating
Experiencing issues relating to frequent disconnects/reconnects or poor performance in certain regions. The team is actively working on investigating this issue.
Posted Aug 28, 2023 - 10:06 PDT
This incident affected: Splashtop remote desktop service.