May have payment issues
Incident Report for Splashtop
Resolved
Zuora has resolved their server degradation and payment process is back to normal
Posted 10 months ago. Jan 11, 2018 - 11:17 PST
Identified
The Zuora service is having server degradation issues currently. This may result in purchase failures at this time. We are working with Zuora to work through this.
Posted 10 months ago. Jan 11, 2018 - 11:13 PST