login problem
Incident Report for Splashtop
Resolved
Issue fixed.
Posted 3 months ago. Sep 29, 2017 - 02:07 PDT
Identified
issue identified.
Posted 3 months ago. Sep 29, 2017 - 01:58 PDT
Investigating
there are reports of login failures. We are investigating.
Posted 3 months ago. Sep 29, 2017 - 01:45 PDT