Scheduled Maintenance announcement
Incident Report for Splashtop
Resolved
The system maintenance is finished.
Posted Apr 12, 2021 - 00:18 PDT
Investigating
We will perform system maintenance now. You may experience service interruption and account login failures during this time. We apologize for any inconvenience.
Posted Apr 12, 2021 - 00:01 PDT
This incident affected: Splashtop web console in EU (my.splashtop.eu).