Unable to reach Splashtop Servers (EU stack)

Incident Report for Splashtop

Resolved

This incident has been resolved.
Posted Apr 15, 2026 - 01:45 PDT

Update

We are continuing to work on a fix for this issue.
Posted Apr 15, 2026 - 01:14 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 15, 2026 - 01:02 PDT

Investigating

(EU stack) Our servers are currently experiencing an issue. You might not be able to log in Splashtop apps or my.splashtop.eu. Our engineers are working to resolve it as soon as possible. We apologize for the inconvenience.
Posted Apr 15, 2026 - 01:01 PDT
This incident affected: Splashtop remote desktop service (EU) and Splashtop web console in EU (my.splashtop.eu).