Scheduled Maintenance
Incident Report for Splashtop
Resolved
Our scheduled maintenance has completed. All services are back to normal. We apologize for any inconvenience this may have caused.
Posted 10 months ago. Jan 14, 2018 - 05:30 PST
Investigating
Our servers are undergoing scheduled maintenance at this time for about 1 hour. We apologize for any inconvenience this may cause.
Posted 10 months ago. Jan 14, 2018 - 04:30 PST