Service interruption
Incident Report for Splashtop
Resolved
This incident has been resolved.
Posted Jun 08, 2021 - 04:04 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 08, 2021 - 03:59 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 08, 2021 - 03:41 PDT
Investigating
Our www.splashtop.com website is currently experiencing an issue due to third party hosting service problem. Our engineers are working to resolve it as soon as possible. We apologize for the inconvenience.
Posted Jun 08, 2021 - 03:33 PDT
This incident affected: Splashtop corporate website.