Unplanned Downtime
Incident Report for Splashtop
Resolved
This incident has been resolved.
Posted 6 months ago. May 24, 2018 - 02:37 PDT
Investigating
Our servers are currently experiencing an issue. You might not be able to access your remote computers at this time. Our engineers are working to resolve it as soon as possible. We apologize for the inconvenience.
Posted 6 months ago. May 24, 2018 - 02:19 PDT
This incident affected: Splashtop remote desktop service.