regional relay server demand increased
Incident Report for Splashtop
Postmortem

approximately 30 minutes after the incident, increased relay servers and capacity

Posted Jul 13, 2020 - 10:00 PDT

Resolved
Some customers reported issues connecting to Splashtop relay servers.
Posted Jul 13, 2020 - 08:30 PDT