Service degradation
Incident Report for Splashtop
Postmortem

The load balancer in one of our regions became unhealthy earlier this morning. We redirected traffic to another region, and all service should be back to normal as of at 9:00AM PDT. We have since rebuilt the affected load balancer, and the full infrastructure has been restored to normal as of 12:30PM PDT.

Posted Nov 01, 2021 - 16:01 PDT

Resolved
Some customers are reporting inability to log in or connect to certain computers. We are investigating and working to resolve as soon as possible. Our apologies for the issues.
Posted Nov 01, 2021 - 07:00 PDT