Page logo

intermittent login failures for users in Australia

Incident Report for Splashtop

Resolved

We have confirmed reports that Splashtop service is working fine for Australia region.
Posted Dec 15, 2020 - 15:18 PST

Investigating

We have received reports on intermittent server login failures for users in Australia. We are investigating the issue.
Posted Dec 15, 2020 - 14:40 PST
This incident affected: Splashtop remote desktop service (Global) and Splashtop web console (my.splashtop.com).