regional service degradation
Incident Report for Splashtop
Resolved
This incident has been resolved.
Posted Mar 25, 2020 - 08:10 PDT
Investigating
We've just confirmed that one of the datacenters in London had degraded network performance this morning between 6:30am to 6:40am PDT resulting in slower-than-normal connections and some disconnections. Connections were automatically rerouted to redundant servers, and all services are recovered and performing normally.
Posted Mar 25, 2020 - 07:07 PDT
This incident affected: Splashtop remote desktop service.