In certain regions, customers are experiencing issues related to disconnects/reconnects or poor performance

Incident Report for Splashtop

Resolved

The service interruption has been mitigated successfully, and our infrastructure provider has confirmed and resolved their issues in US West. We will continue to monitor closely - if you are continuing to experiencing issues, please reach out to our support team. Thanks again for your patience and support - we know these interruptions are disruptive, and will continue to work with our providers to minimize these disruptions.
Posted Oct 13, 2023 - 14:09 PDT

Identified

Connectivity issues have been localized to one of our infrastructure providers in the US-West zone. We are spinning up additional relays with our other providers and reassigning connections to those. We apologize for the inconvenience and appreciate your patience.
Posted Oct 13, 2023 - 12:21 PDT

Update

We are actively investigating the issue and sincerely appreciate your patience
Posted Oct 13, 2023 - 10:23 PDT

Investigating

We are currently investigating this issue.
Posted Oct 13, 2023 - 10:22 PDT
This incident affected: Splashtop remote desktop service (Global).